読者です 読者をやめる 読者になる 読者になる

Alamofire 3.3.0 のコンパイルエラーの問題

Swift iOS8 Development

お疲れ様です。こんにちは。

InagoraのiOS/Android技術者のティーラット(ボール)でございます。
本日のblogもよろしくお願いします。

Swiftで開発しているみんなさんはAlamofireを知っていると思いますが、
Alamofireとは?
簡単に言うと、Alamofire = Swift版のAFNetworking です。

Alamofireをv.3.3.0にアップデートした人はこういうコンパイルエラーを経験したことがありますか。

http://i.stack.imgur.com/kqUGS.png

エラーになる原因はSwiftバージョンが古過ぎて、必要のバージョンはSwift2.2です。

ですから、Swiftをバージョンアップしないと、。。。。。 でも、どうやってアップするのか?

答えは Xcode7.3 にアップデート!

Xcode7.3にはSwift2.2が付いてありますので大丈夫です。

しかし、Xcode7.3アップデートのため、macOS古過ぎたらXcode7.3アップデートできませんよ。

最低限のOSは最新版の「OS X El Capitan(OS X 10.11)」です。

つまり: El Capitanにアップデートして、Xcode7.3にアップデートして、Alamofire3.3.0が使えるようになりました。

ありがとうございます
ティーラット(ボール)

PS. El Capitanはかなり重いので、にアップデートする前に、メモリとかパソコンのスペックなどを確認してくださいね。^0^